Home / Disciplinas / Licenciatura em Engenharia Informática / ArqC-0910 / Forum Arquitectura de Computadores 2009/2010 / Simulador Y86

Simulador Y86

You need to be logged in to get access to the forums. You can do so here

Author Message

Ricardo Amaral

Domingo, 11 de Outubro de 2009, 18:03:25

Olá,

No enunciado do módulo 1 é dito que podemos verificar os nossos resultados usando o assembler do Y86. Onde é que possível arranjar estas ferramentas para brincar com o simulador do Y86?

Cumprimentos,
Ricardo Amaral

Cumprimentos,
Ricardo Amaral

Daniel Santos

Domingo, 11 de Outubro de 2009, 22:37:37

Boas.
Para já, começo por agradecer ao professor pela criação deste fórum. Acho uma boa ideia a possibilidade de podermos falar e discutir tudo directamente no site. Uma excelente ideia e uma grande iniciativa.
Consegues encontrar o simulador neste site http://csapp.cs.cmu.edu/public/students.html . Se procurares tem lá no Chapter 4
Eu como tou em linux (kubuntu 8.04 kde 3.5) tentei compilar os pacotes que dao nesse site. Mas acabou por dar sempre erros na compilação.
Acabei por sacar os binários para Linux/Pentium e funcionou.me perfeitamente
Espero que tenha ajudado. Diz ai se conseguiste.
Já agora, se alguem conseguiu sacar o source code e compilou sem erros partilhem como fizeram
um abraco

daniel

João Alpuim

Quarta-Feira, 14 de Outubro de 2009, 15:38:57

Para mim bastou mudar na makefile a localizacao das libs e headers tk e tcl.
No meu caso:

TKLIBS=-L/usr/lib -ltk8.5 -ltcl8.5

TKINC=-L/usr/include

De qualquer forma podem sempre comentar essas linhas, de forma a instalarem sem o gui (leiam a makefile).

Luis Santos

Quinta-Feira, 15 de Outubro de 2009, 12:38:31

Viva,

O simulador do Y86, útil para várias sessões TP e para ajudar à compreensão genérica da arquitectura e organização deste processador, pode ser encontrado aqui (http://csapp.cs.cmu.edu/public/students.html), na secção "Chapter 4: Processor Architecture" - notem que a aqruitectura alvo (do simulador) são máquinas com o Sistema Operativo Linux ; não sei nada sobre versões para Windows. A versão gráfica exige a disponibilidade do Tcl/Tk -se não tiverem estes pacotes instalados (e não os quiserem instalar) podem sempre usar a versão alfanumérica.

Luis Paulo Santos